Ankündigung

Einklappen
Keine Ankündigung bisher.

Benötige Hilfe!

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Benötige Hilfe!

    Hallo,

    nur auf meiner Startseite des Webshopes wird oben angezeigt:
    Die Verbindung ist nicht uneingeschränkt sicher.
    Auf allen weiteren Unterseiten ist alles in Ordnung und ein gültiges Zertifikat habe ich auch. An einer Stelle des Quellcodes zeigt es eine http Verbindung statt einer https Verbindung an. Dies soll ich umschreiben. Aber wie, bin kein Experte! ;-)


  • #2
    Hallo Thomas75,

    hast Du im Server Backend (Strato) SSL erzwingen aktiviert?

    Wenn ja, deaktivieren.

    Mfg
    hpb
    Zuletzt geändert von hpbdesign; 05.08.2018, 13:51.
    https://www.frw-shop.de/
    Strato, Version: 6.17.79 - ePages Base
    Fürchte Dich nicht langsam zu gehen, fürchte Dich nur stehen zu bleiben.
    (Chinesische Weisheit)
    https://hpbdesign.eu/

    Kommentar


    • #3
      Zitat von Thomas75 Beitrag anzeigen
      Hallo,

      nur auf meiner Startseite des Webshopes wird oben angezeigt:
      Die Verbindung ist nicht uneingeschränkt sicher.
      Auf allen weiteren Unterseiten ist alles in Ordnung und ein gültiges Zertifikat habe ich auch. An einer Stelle des Quellcodes zeigt es eine http Verbindung statt einer https Verbindung an. Dies soll ich umschreiben. Aber wie, bin kein Experte! ;-)
      Hallo Thomas75,

      schau mal im Quelltext nach, vor welchem Link das http anstatt https steht und ändere das entsprechend ab. Du solltest wissen, wo du was eingefügt hast. Die Angaben die auf der Startseite stehen, fügst/änderst du im BO unter dem Tab Inhalt/Kategorien >> Allgemein.
      Schöne Grüße
      Micro

      Strato-Advanced

      Kommentar


      • #4
        Hallo,
        ich habe genau daas gleiche "Problem". Habe - wie Micro empfiehlt - im Quelltext nachgeschaut. Bei mir steht gleich 3 Mal vor einem Link http, statt https, aber das gehört zum Link und lässt sich manuell nicht ändern. Was mache ich falsch?
        Lg Junisa

        Kommentar


        • #5
          Hallo,

          um den Link zu ändern müsst ihr im BO unter dem Tab Inhalt/Kategorien >> Allgemein in den erweiterten Beschreibungen auf das Zeichen des Quellcodes klicken, damit ihr im entsprechendenLink das "s" einfügen könnt.
          Schöne Grüße
          Micro

          Strato-Advanced

          Kommentar


          • #6
            Hallo Junisa,

            bei dir sind lt. Seitenquelltext einige Links mit http: drin. Hast du bei Strato deinen Shop auf https umgestellt?
            Schöne Grüße
            Micro

            Strato-Advanced

            Kommentar


            • #7
              Hi Micro, danke für deine Antwort. Nein.... musste ich das? Hab keine Ahnung, habe einfach den Shop eingerichtet und so "gelassen". Was ist denn BO? Sorry für die blöde Frage, aber ich hab da echt null Ahnung von sowas

              Kommentar


              • #8
                Ihr Lieben,
                also bei mir ist auch alles ohne das "S". Jeder Link, welcher erstellt wird, z.B. wenn ich ein neues Produkt anlege kommt mit http. ohne "S". Hab jetzt mal bei Strato nachgeschaut.
                Bevor ich ein falsches Häckchen setzte und alles schlimmer mache (ist mir schon passiert) bitte ich um Hilfe.

                Was muss ich denn machen? Kann sich bitte jemand von euch meinen Screenshop anschauen und mir Rat geben?

                Herzlichen Dank.
                Provider: Strato - Shop: Ultimate Shop

                Kommentar


                • #9
                  Zitat von junisa Beitrag anzeigen
                  Hi Micro, danke für deine Antwort. Nein.... musste ich das? Hab keine Ahnung, habe einfach den Shop eingerichtet und so "gelassen". Was ist denn BO? Sorry für die blöde Frage, aber ich hab da echt null Ahnung von sowas
                  Bei mir ist das schon etwas länger her, damals musste ich die Seite direkt unter meinem Strato Account auf SSL umstellen. Leider weiß ich im Moment auswendig auch nicht mehr genau wie das ablief. Vielleicht kann dir jemand vom Forum oder von Strato oder deren Hilfeseiten behilflich sein.

                  BO ist die Benutzeroberfläche deines Shops in der du die ganzen Änderungen, Artikelpflege usw. machst und FO ist die Shopansicht für deine Kunden.
                  Schöne Grüße
                  Micro

                  Strato-Advanced

                  Kommentar


                  • #10
                    Danke Micro!
                    das stimmt, ich musste "SSL erzwingen" aktivieren. Das wusste ich vorher nicht. Hab es gemacht und es klappte zuerst. Bekomme dort auch die Info, daß alle Aufrufe meiner Seite auf https umgeleitet werden. Hat auch vorhin alles super funktioniert und das kleine Schloss oben in der Eingabeleiste war grün. Keine Ahnung warum, aber jetzt ist es wieder rot durchgestrichen, mit dem Vermerk "Verbindung ist nicht sicher".

                    Kommentar


                    • #11
                      Bei mir funktioniert folgendes:

                      Strato> Webshop Einstellungen:

                      Sicherheit-Strato-SSL: Siehe Bild

                      Domains-Webshop-Umleitung: Siehe Bild
                      https://www.frw-shop.de/
                      Strato, Version: 6.17.79 - ePages Base
                      Fürchte Dich nicht langsam zu gehen, fürchte Dich nur stehen zu bleiben.
                      (Chinesische Weisheit)
                      https://hpbdesign.eu/

                      Kommentar


                      • #12
                        Hallo zusammen,

                        kleine Richtigstellung, in der Hoffnung dass dann jeder von Euch den richtigen Ansatzpunkt findet:

                        1. Wie HPdesign schon sagte: es ist NICHT erforderlich, dass man bei Strato (Kundenlogin) im Shoppaket "SSL erzwingen" aktiviert.
                        2. Man muss für's Shoppaket drei Schritte ausführen - und ich meine dass ggf. der dritte Schritt bei Euch (Thomas75, junisa, what to do) noch fehlt. Info siehe unten.
                        3. Korrektur zu Micro: Die Stelle stimmt nicht. Im BO unter "Einstellungen" -> "Allgemein" steht dann https:// vor dem Websitename. Das ergibt sich aber automatisch, nachdem der dritte Schritt (was ich hier oben bei 2. geschrieben habe) ausgeführt worden ist.

                        Hier die 3 SCHRITTE, um zur https-Schreibweise in der Browserzeile zu kommen:
                        1. Das SSL aktivieren (ich gehe jetzt mal vom integrierten SSL aus, das ohne Aufpreis erhältlich ist). Das habt ihr ja schon gemacht und das Zertifikat ist Euch von Strato bestätigt worden.
                        2. Zuweisung der Domain zum Zertifikat. Dazu muss man sich bei Strato einloggen, "Ihr Paket" auswählen und dort dann "SSL zuweisen".
                        3. Man muss auch eine Webshop-Umleitung einstellen, damit das SSL komplett für den Shop gilt (Achtung, für Subdomains gilt das integrierte Zertifikat meist nicht, es kommt auf die Art an, wie eventuelle Subdomains angelegt wurden). Die Webshop-Umleitung geht so: Bei Strato einloggen, "Ihr Paket" auswählen, dann oben links im Menü "Domains" anklicken. Hier öffnet sich ein Untermenü -> "Webshop-Umleitung". Wenn man da drauf klickt, wird eine Tabelle angezeigt, in der der Shopname steht. Hier drunter befindet sich ein kleines Kästchen "SSL für Shop aktivieren" -> Dieses Kästchen muss angehakt sein.

                        Wenn dieses Kästchen angehakt ist, dann sollte in Euerem BO (Shop-Administration) automatisch die htttps-Schreibweise stehen, wie eingangs unter 3. gesagt. Ruft man dann z.B. mal den Quellcode auf, dann steht auch hier überall das https in den Links.

                        That's it Ich hoffe, ich konnte Euch weiterhelfen.

                        Grüße
                        Evelyn

                        Kommentar


                        • #13
                          Danke, Danke, Danke!
                          Ich hab endlich ein grünes Häckchen im Shop. Es war tatsächlich bei nur "einem" Link das fehlende S!

                          Ohne euch hätte ich das nie rausgefunden.
                          Provider: Strato - Shop: Ultimate Shop

                          Kommentar


                          • #14
                            Hat sich bei mir auch zum Glück erledigt und ich habe ENDLICH!!! auch mein grünes Häkchen! Musste unter Domainumleitung tatsächlich auch noch ein Häkchen setzen! Wäre ich von alleine auch nie drauf gekommen also DANKE!!!!

                            Kommentar

                            Lädt...
                            X